مسرد المصطلحات — الأمن

ما هو تشفير AES-GCM

هذه الصفحة مترجمة آليًا من الأصل الياباني. اقرأ الأصل الياباني

AES-GCM هي طريقة تجمع بين التشفير والتحقق من العبث. يمكنك شرح دور Nonce وعلامات المصادقة، والاختلاف عن الطرق الأخرى، ونطاق الحماية في التطبيق، وفشل التحقق من الاختبار في المتصفح.

AES-GCM هي طريقة تشفر النص وتستخدم المفاتيح للتحقق من العبث.الفرضية هي أنه يجب التعامل مع علامات المفتاح وnonce والمصادقة بشكل صحيح. لا يحدد اسم طريقة التشفير وحده نطاق الحماية، بما في ذلك الوجهة والنسخ الاحتياطي للبريد الإلكتروني.

تم التحديث: 9 سبتمبر 2026. لقد أكدنا المواد الأساسية ل NIST و IETF و Apple وتنفيذ الإصدار العام SimpleMemo 5.8.26. المؤلف هو مطور SimpleMemo.

ماذا تفعل الجمل المشفرة، nonce، والعلامات؟

AES هو تشفير المفتاح المشترك، وGCM هو وضع التشغيل الخاص به. AES-GCM هو AEAD يتعامل مع النصوص المشفرة والبيانات الإضافية (AAD) التي يتم توثيقها بدون تشفير. على سبيل المثال، أثناء إخفاء النص، يمكنك التحقق من رقم إصدار التنسيق باستخدام النص. AAD نفسه ليس سرا.

nonce(IV) هي قيمة لكل تشفير، ويجب تصميمها لعدم إعادة استخدامها بنفس المفتاح. المفتاح السري له دور مختلف ويمكن حفظه باستخدام نص مشفر. تستخدم علامة المصادقة للتحقق عند فك التشفير. لن يتم اعتماد البيانات التي تفشل في التحقق وسيتم التعامل معها على أنها خطأ.

تعريف الطريقة: NIST SP 800-38D. شروط الإدخال والغير: RFC 5116.

ماذا يحدث إذا قمت بتغيير نص التشفير؟

ستتم معالجة الجمل النموذجية المعدة في هذه الصفحة فقط بواسطة Web Crypto API في المتصفح. أولا، تأكد من إمكانية تشفيره والتراجع عنه، ثم تحقق من نسخة نص التشفير عن طريق تغيير بت 1. هذا ليس عرضا توضيحيا لتدقيق عملية تشفير التطبيق.

مثال على جملة: Review the draft at 10:00.

لا يمكن تشغيل العرض التوضيحي في هذه البيئة. مطلوب متصفح متوافق مع HTTPS وJavaScript.

ينشئ كل تشغيل مفتاحًا جديدًا بطول 256 بت وnonce جديدًا. لا يحفظ العرض التجريبي المفتاح أو النتائج ولا يرسلها. تُصفَّر النتائج عند إعادة تحميل التبويب. الآلية: AES-GCM في Web Cryptography API.

الفرق من AES-CBC・ChaCha20-Poly1305

الاختلافات في الطريقة هي كما يلي. تتغير السرعة اعتمادا على المحطة الطرفية والتنفيذ، وهذا الجدول ليس ترتيبا فعليا للقياس. استنادا إلى المعلومات التي يتم استخدام CBC، لا يمكن تحديد سلامة المنتج بأكمله جنبا إلى جنب مع المصادقة.

العنصرAES-GCMAES-CBCChaCha20-Poly1305
التشفير والمصادقةالنوع المتكامل (AEAD)CBC وحده مشفر فقطالنوع المتكامل (AEAD)
استخدام AESاستخداماستخداملا تستخدم
تأكيد مع التصميمقفل، نونس، علامة، الحد الأعلى للاستخدامالجمع مع المصادقة، الرابع، معالجة الحشوقفل، نونس، علامة، الحد الأعلى للاستخدام

TLS 1.3 ليس المعيار الوحيد ل AES-GCM. RFC 8446 §9.1 يتطلب تنفيذ AES-128-GCM، كما يوصى ب AES-256-GCM وChaCha20-Poly1305. يرجى الرجوع إلى RFC 8439 للحصول على مواصفات ChaCha20-Poly1305.

ما هي البيانات التي تحميها SimpleMemo؟

تستخدم عملية الحفظ المحلي في النسخة المنشورة التي فحصناها AES-GCM عبر CryptoKit من Apple ومفتاحاً تديره Keychain. طول المفاتيح الجديدة 256 بت. Outbox مكان لحفظ البيانات المنتظرة للإرسال؛ ولا يبرر هذا التشفير القول بأن البريد يصل إلى وجهته بتشفير E2E.

يقرأ هذا التنفيذ مفتاحًا متماثلًا من Keychain ويستخدمه. المفتاح المحفوظ في Keychain ليس الوصف نفسه لمفتاح خاص يُنشأ ويُستخدم داخل Secure Enclave. توضح وثائق Apple الخاصة بـ حفظ مفاتيح CryptoKit ومفاتيح Secure Enclave الفرق في الاستخدام.

عند إرسال بريد إلكتروني، يتم ترك نسخة على الجانب المتلقي عبر شركة معالجة الترحيل وتسليمه في التطبيق. بالتزامن مع طريقة التشفير، يرجى التحقق من سياسة الخصوصية، إعداد العنوان وتأكيد الوصول، وإدارة حساب المحطة الطرفية والبريد الإلكتروني. العناصر التي تختفي من Outbox وتمحو جميع النسخ تماما مختلفة.

الأسئلة الشائعة

ما هو "256" ل AES-256-GCM؟

هذا يعني أن طول مفتاح AES هو 256 بت. إنه ليس رقما يمثل طول Nonce أو علامات المصادقة أو سلامة المحطة بأكملها.

هل أحتاج إلى الحفاظ على سرية؟

nonce يختلف عن المفتاح الخاص ويمكن حفظه باستخدام نص مشفر. الشيء المهم هو عدم إعادة استخدام nonce عند التشفير بنفس المفتاح.

، فهل يمكنني عرض النص؟

لا تستخدم نتائج التحقق الفاشل كنصوص واضحة صحيحة. يتم فصل الفساد والمفاتيح الخاطئة والبيانات المتغيرة وما إلى ذلك، ويتم التعامل مع أخطاء المصادقة.

هل يمكنني الحصول على تشفير E2E إذا استخدمت AES-GCM؟

لا يمكن تحديد اسم الطريقة وحده. من الضروري تصميم النظام بأكمله، بما في ذلك من لديه المفتاح وأين يتم فك تشفيره. يختلف تشفير الOutboxي في المحطة الطرفية وحفظ رسائل البريد الإلكتروني في الوجهة.

إذا قمت بحفظ سلسلة المفاتيح، ألن يخرج المفتاح من Secure Enclave؟

هذا ليس هو الحال بالضرورة. يقرأ التنفيذ الذي يؤكده هذا التطبيق ويستخدم بيانات المفاتيح المتماثلة من سلسلة المفاتيح. إنه ليس مثل API، الذي يحسب المفاتيح الخاصة في Secure Enclave.

حدد الوجهة واترك ملاحظة نصية
SimpleMemo هو تطبيق يترك الأحرف المكتوبة بلغة iPhone إلى عنوان البريد الإلكتروني المحدد أو Obsidian. يمكنك البدء بالتحقق من الاتصال وحفظ إعدادات الوجهة.
تحميل من App Store

الصفحات ذات الصلة