O que é criptografia AES-GCM
Esta página é uma tradução automática do original em japonês. Ler o original em japonês
AES-GCM é um método que combina criptografia e verificação de adulteração. Você pode explicar o papel do Nonce e as tags de autenticação, a diferença de outros métodos e o escopo da proteção no aplicativo e a falha de verificação do teste no navegador.
Atualização: 9 de setembro de 2026. Confirmamos os materiais primários do NIST, IETF e Apple e a implementação da versão pública SimpleMemo 5.8.26. O autor é o desenvolvedor do SimpleMemo.
O que as frases criptográficas, nonce e tags fazem?
AES é a criptografia de chave comum, e GCM é seu modo de operação. AES-GCM é um AEAD que lida com texto criptografado e dados adicionais (AAD) que são autenticados sem criptografia. Por exemplo, enquanto oculta o texto, você pode verificar o número da versão do formato com o texto. O AAD em si não é um segredo.
nonce(IV) é um valor para cada criptografia e deve ser projetado para não ser reutilizado com a mesma chave. A chave secreta tem um papel diferente e pode ser salva com um texto cifrado. A tag de autenticação é usada para verificar ao descriptografar. Os dados que não forem verificados não serão adotados e serão tratados como um erro.
Definição do método: NIST SP 800-38D. Condições de entrada e nonce: RFC 5116.
O que acontece se você alterar o texto cifrado?
Apenas as frases de exemplo preparadas nesta página são processadas pelo navegador Web Crypto API. Primeiro, confirme se ele pode ser criptografado e desfeito e, em seguida, verifique a cópia do texto cifrado alterando o bit 1. Esta não é uma demonstração para auditar o processo de criptografia do aplicativo.
Exemplo de frase: Review the draft at 10:00.
Você pode tentar no primeiro botão.
Processando...
Verificação bem-sucedida: Consegui descriptografá-lo para a frase de exemplo original.
Falha na verificação: O texto cifrado alterado foi rejeitado e o texto simples não foi retornado.
O processamento não pôde ser concluído. Você pode começar de novo a partir do primeiro botão.
A demonstração não pode ser executada neste ambiente. Um navegador compatível com HTTPS e JavaScript são necessários.
- nonce(12 bytes)
- Texto do código original (decimal 16)
- Tag de autenticação (16 bytes)
Crie uma nova chave de bits 256 e nonce toda vez que você executar . A demonstração não salva ou transmite chaves ou resultados. Se você recarregar a guia, o resultado será redefinido. Mecanismo: Criptografia Web API's AES-GCM.
Diferença de AES-CBC・ChaCha20-Poly1305
As diferenças no método são as seguintes. A velocidade muda dependendo do terminal e da implementação, e esta tabela não é uma classificação de medição real. Com base nas informações que a CBC é usada, a segurança de todo o produto combinada com a autenticação não pode ser determinada.
| Item | AES-GCM | AES-CBC | ChaCha20-Poly1305 |
|---|---|---|---|
| Criptografia e autenticação | Integrado (AEAD) | O CBC sozinho é criptografado apenas | Integrado (AEAD) |
| Uso de AES | Use | Use | Não use |
| Confirmar no design | Bloqueio, nonce, tag, limite superior de uso | Combinação com autenticação, IV, processamento de preenchimento | Bloqueio, nonce, tag, limite superior de uso |
TLS 1.3 não é o único padrão para AES-GCM. RFC 8446 §9.1 requer a implementação de AES-128-GCM, e AES-256-GCM e ChaCha20-Poly1305 também são recomendados. Consulte RFC 8439 para as especificações do ChaCha20-Poly1305.
Quais dados o SimpleMemo protege?
O processamento de armazenamento local da versão pública confirmada usa as chaves de gerenciamento AES-GCM e Keychain pelo CryptoKit da Apple. A chave a ser gerada recentemente é 256 bits. Outbox é o local de armazenamento de dados aguardando transmissão e, com base nessa criptografia, não se pode dizer que "os e-mails também são criptografados com E2E para o destino".
Esta implementação lê e usa chaves simétricas da Keychain. A chave armazenada no Chaveiro e a chave privada gerada e usada no Secure Enclave não são a mesma explicação. A Save CryptoKit key e a Secure Enclave do Apple explicam como usá-las separadamente.
Ao enviar um e-mail, uma cópia é deixada no lado receptor através da empresa de processamento e entrega de retransmissão do aplicativo. Em conjunto com o método de criptografia, verifique política de privacidade, configuração de endereço e confirmação de chegada e gerenciamento de conta de terminal e e-mail. O desaparecimento de itens do Outbox e a exclusão completa de todas as cópias são separadas.
Perguntas Frequentes
Qual é o "256" de AES-256-GCM?
Isso significa que o comprimento da chave AES é 256 bits. Não é um número que representa o comprimento do Nonce, as tags de autenticação ou a segurança de todo o terminal.
Preciso manter o nonce em segredo?
Ao contrário das chaves privadas, o nonce pode ser armazenado com um texto cifrado. O importante é não reutilizar o nonce ao criptografar com a mesma chave.
falhar, posso exibir o texto?
Não use o resultado da falha na verificação como o texto simples correto. Corrupção, chaves erradas, dados alterados, etc. são separados e erros de autenticação são tratados.
Posso usar o AES-GCM para criptografar o E2E?
O nome do método sozinho não pode ser determinado. É necessário projetar todo o sistema, incluindo quem tem a chave e onde ela é descriptografada. A criptografia Outbox no terminal e o salvamento no destino da entrega e recebimento de correspondência são diferentes.
Se você salvar o Keychain, a chave não sairá do Secure Enclave?
Esse não é necessariamente o caso. A implementação confirmada por este aplicativo lê e usa dados de chaves simétricas do Keychain. Não é o mesmo que API, que calcula chaves privadas no Secure Enclave.