Daftar Istilah — Keamanan

Apa itu enkripsi AES-GCM

Halaman ini diterjemahkan secara otomatis dari bahasa Jepang. Baca versi asli berbahasa Jepang

AES-GCM adalah metode yang menggabungkan enkripsi dan verifikasi gangguan. Anda dapat menjelaskan peran Nonce dan tag otentikasi, perbedaan dari metode lain, dan cakupan perlindungan dalam aplikasi, dan uji kegagalan verifikasi di browser.

AES-GCM adalah metode yang menggunakan kunci untuk memverifikasi gangguan saat mengenkripsi teks.Diasumsikan bahwa kunci, nonce, dan tag otentikasi ditangani dengan benar. Nama metode enkripsi saja tidak menentukan ruang lingkup perlindungan, termasuk tujuan dan cadangan email.

Pembaruan: 9 September 2026. Kami telah mengkonfirmasi materi utama NIST, IETF, dan Apple dan implementasi versi publik SimpleMemo 5.8.26. Penulisnya adalah pengembang SimpleMemo.

Apa yang dilakukan oleh kalimat kriptografi, nonce, dan tag?

AES adalah enkripsi kunci umum, dan GCM adalah mode operasinya. AES-GCM adalah AEAD yang menangani teks terenkripsi dan data tambahan (AAD) yang diautentikasi tanpa enkripsi. Misalnya, saat menyembunyikan teks, Anda dapat memverifikasi nomor versi format dengan teks. AAD sendiri bukanlah sebuah rahasia.

nonce(IV) adalah nilai untuk setiap enkripsi, dan harus dirancang agar tidak digunakan kembali dengan kunci yang sama. Kunci rahasia memiliki peran yang berbeda dan dapat disimpan dengan ciphertext. Tag otentikasi digunakan untuk memverifikasi saat mendekripsi. Data yang gagal diverifikasi tidak akan diadopsi dan akan diperlakukan sebagai kesalahan.

Definisi metode: NIST SP 800-38D. Masukan dan kondisi nonce: RFC 5116.

Apa yang terjadi jika kamu mengubah kalimat kode?

Hanya contoh kalimat yang disiapkan di halaman ini yang akan diproses dengan browser Web Crypto API. Pertama, konfirmasikan bahwa itu dapat dienkripsi dan dibatalkan, lalu verifikasi salinan teks sandi dengan mengubah bit 1. Ini bukan demo untuk mengaudit proses enkripsi aplikasi.

Contoh kalimat: Review the draft at 10:00.

Demo tidak dapat dijalankan di lingkungan ini. Diperlukan peramban yang kompatibel dengan HTTPS dan JavaScript.

Buat kunci bit 256 baru dan nonce setiap kali Anda menjalankan . Demo tidak menyimpan atau mengirimkan kunci atau hasil. Jika Anda memuat ulang tab, hasilnya akan diatur ulang. Mekanisme: Kriptografi Web API's AES-GCM.

Perbedaan dari AES-CBC・ChaCha20-Poly1305

Perbedaan dalam metode ini adalah sebagai berikut. Kecepatan berubah tergantung pada terminal dan implementasi, dan tabel ini bukan peringkat pengukuran yang sebenarnya. Berdasarkan informasi bahwa CBC digunakan, keamanan seluruh produk yang dikombinasikan dengan otentikasi tidak dapat ditentukan.

BarangAES-GCMAES-CBCChaCha20-Poly1305
Enkripsi dan otentikasiTipe terintegrasi (AEAD)CBC saja hanya dienkripsiTipe terintegrasi (AEAD)
Penggunaan AESGunakanGunakanJangan gunakan
Untuk mengonfirmasi dalam desainKunci, nonce, tag, batas atas penggunaanKombinasi dengan otentikasi, IV, pemrosesan paddingKunci, nonce, tag, batas atas penggunaan

TLS 1.3 bukan satu-satunya standar dari AES-GCM. RFC 8446 §9.1 memerlukan implementasi AES-128-GCM, dan AES-256-GCM dan ChaCha20-Poly1305 juga direkomendasikan. Silakan merujuk ke RFC 8439 untuk spesifikasi ChaCha20-Poly1305.

Data apa yang dilindungi SimpleMemo?

Pemrosesan penyimpanan lokal dari versi publik yang dikonfirmasi menggunakan kunci manajemen AES-GCM dan Keychain oleh CryptoKit Apple. Kunci yang baru dibuat adalah bit 256. Outbox adalah lokasi penyimpanan data yang menunggu transmisi, dan berdasarkan enkripsi ini, tidak dapat dikatakan bahwa "email juga dienkripsi dengan E2E ke tujuan".

Implementasi ini membaca kunci simetris dari Keychain untuk digunakan. Kunci yang disimpan di Keychain berbeda dari kunci privat yang dibuat dan digunakan di dalam Secure Enclave. Dokumentasi Apple tentang penyimpanan kunci CryptoKit dan kunci Secure Enclave menjelaskan perbedaan penggunaannya.

Saat mengirim email, salinannya tertinggal di sisi penerima melalui perusahaan pemrosesan dan pengiriman relai aplikasi. Dalam hubungannya dengan metode enkripsi, silakan periksa kebijakan privasi, pengaturan alamat dan konfirmasi kedatangan, dan manajemen terminal dan akun email. Hilangnya barang-barang dari Outbox dan penghapusan lengkap dari semua salinan terpisah.

Pertanyaan yang Sering Diajukan

Apa itu "256" dalam AES-256-GCM?

Itu berarti bahwa panjang kunci AES adalah 256 bit. Ini bukan angka yang mewakili panjang Nonce, tag otentikasi, atau keamanan seluruh terminal.

Apakah saya perlu merahasiakannya?

nonce berbeda dari kunci pribadi dan dapat disimpan dengan ciphertext. Yang penting adalah jangan menggunakan kembali nonce saat mengenkripsi dengan kunci yang sama.

gagal, dapatkah saya menampilkan teksnya?

Jangan gunakan hasil verifikasi yang gagal sebagai teks biasa yang benar. Korupsi, kunci yang salah, data yang diubah, dll. dipisahkan, dan kesalahan otentikasi ditangani.

Apakah saya akan mendapatkan enkripsi E2E jika saya menggunakan AES-GCM?

Nama metode saja tidak dapat ditentukan. Penting untuk merancang seluruh sistem, termasuk siapa yang memiliki kunci dan di mana kuncinya didekripsi. Enkripsi Outbox di terminal dan penyimpanan di tempat tujuan pengiriman dan penerimaan surat berbeda.

Jika kunci disimpan di Keychain, apakah kunci tetap berada di Secure Enclave?

Belum tentu. Implementasi aplikasi yang telah diperiksa membaca data kunci simetris dari Keychain untuk digunakan. Ini berbeda dari API, yang melakukan operasi kunci privat di dalam Secure Enclave.

Tentukan tujuan dan tinggalkan catatan teks
SimpleMemo adalah sebuah aplikasi yang meninggalkan karakter yang ditulis dalam iPhone ke alamat email yang ditetapkan atau Obsidian. Anda dapat memulai dengan memeriksa koneksi dan menyimpan pengaturan tujuan.
Unduh dari App Store

Halaman terkait