Glosario — Seguridad

¿Qué es el cifrado AES-GCM?

Esta página es una traducción automática del original en japonés. Leer el original en japonés

AES-GCM es un método que combina cifrado y verificación de manipulación. Puede explicar el papel de Nonce y las etiquetas de autenticación, la diferencia con otros métodos, el alcance de la protección en la aplicación, y la verificación de prueba fallida en el navegador.

AES-GCM es un método que utiliza claves para verificar la manipulación al cifrar textos.Se supone que puede manejar claves, nonce y etiquetas de autenticación correctamente. El nombre del método de cifrado por sí solo no determina el alcance de la protección, incluido el destino y la copia de seguridad del correo electrónico.

Actualización: 9 de septiembre de 2026. Hemos confirmado los materiales primarios de NIST, IETF y Apple y la implementación de la versión pública SimpleMemo 5.8.26. El autor es el desarrollador de SimpleMemo.

¿Qué hacen las oraciones criptográficas, el nonce y las etiquetas?

AES es un cifrado de clave común, y GCM es su modo de funcionamiento. AES-GCM es un AEAD que maneja texto cifrado y datos adicionales (AAD) que se autentican sin cifrado. Por ejemplo, mientras oculta el texto, puede verificar el número de versión del formato con el texto. AAD en sí no es un secreto.

nonce(IV) es un valor para cada cifrado, y debe estar diseñado para no reutilizarse con la misma clave. La clave secreta tiene un papel diferente y se puede guardar con un texto cifrado. La etiqueta de autenticación se utiliza para verificar al descifrar. Los datos que no se verifiquen no serán adoptados y serán tratados como un error.

Definición del método: NIST SP 800-38D. Condiciones de entrada y nonce: RFC 5116.

¿Qué pasa si cambias la oración del código?

Solo las oraciones de ejemplo preparadas en esta página se procesarán con el navegador Web Crypto API. Primero, confirme que se puede cifrar y deshacer, y luego verifique la copia del texto cifrado cambiando el bit 1. Esta no es una demostración para auditar el proceso de cifrado de la aplicación.

Oración de ejemplo: Review the draft at 10:00.

La demostración no se puede ejecutar en este entorno. Se requiere un navegador compatible con HTTPS y JavaScript.

Crea una nueva clave de bits 256 y nonce cada vez que ejecutes . La demostración no guarda ni transmite claves ni resultados. Si vuelve a cargar la pestaña, el resultado se restablecerá. Mecanismo: Criptografía Web API's AES-GCM.

Diferencia de AES-CBC・ChaCha20-Poly1305

son las siguientes. La velocidad cambia dependiendo del terminal y la implementación, y esta tabla no es una clasificación de medición real. Basándose en la información que se utiliza CBC, no se puede determinar la seguridad de todo el producto combinado con la autenticación.

ArtículoAES-GCMAES-CBCChaCha20-Poly1305
Cifrado y autenticaciónIntegrado (AEAD)Solo CBC solo está encriptadoIntegrado (AEAD)
Uso de AESUsoUsoNo usar
Para confirmar en el diseñoTecla, nonce, etiqueta, límite superior de usoCombinación con autenticación・IV・Procesamiento de acolchadoTecla, nonce, etiqueta, límite superior de uso

TLS 1.3 no es solo un estándar para AES-GCM. RFC 8446 §9.1 requiere la implementación de AES-128-GCM, y también se recomiendan AES-256-GCM y ChaCha20-Poly1305. Consulte RFC 8439 para conocer las especificaciones de ChaCha20-Poly1305.

¿Qué datos protege SimpleMemo?

El procesamiento de almacenamiento local de la versión pública confirmada utiliza las claves de gestión AES-GCM y Keychain de CryptoKit de Apple. La clave que se generará recientemente es 256 bits. La Outbox es la ubicación de almacenamiento de los datos que esperan ser enviados, y basado en este cifrado, no se puede decir que "los correos electrónicos también están encriptados al destino E2E".

Esta implementación lee y utiliza claves simétricas de Keychain. La clave almacenada en el llavero y la clave privada generada y utilizada en el Secure Enclave no son la misma explicación. La Clave CryptoKit y la clave Secure Enclave de Apple explican cómo usarlas por separado.

Al enviar un correo electrónico, se deja una copia en el lado receptor a través de la empresa de procesamiento y entrega de retransmisión de la aplicación. Junto con el método de cifrado, consulte la política de privacidad, la configuración de la dirección y la confirmación de llegada, y la gestión del terminal y de la cuenta de correo electrónico. Los artículos que desaparecen de la Outbox y borran por completo todas las copias son diferentes.

Preguntas frecuentes

¿Cuál es el "256" de AES-256-GCM?

Significa que la longitud de la clave AES es 256 bits. No es un número que represente la longitud de Nonce, las etiquetas de autenticación o la seguridad de todo el terminal.

¿Necesito mantener el nonce en secreto?

nonce es diferente de una clave privada y se puede guardar con un texto cifrado. Lo importante es no reutilizar nonce al cifrar con la misma clave.

falla, ¿puedo mostrar el texto?

No utilice el resultado de la verificación fallida como el texto sin formato correcto. La corrupción, las claves incorrectas, los datos modificados, etc. se separan y se manejan los errores de autenticación.

¿Puedo obtener el cifrado E2E si uso AES-GCM?

El nombre del método por sí solo no se puede determinar. Es necesario diseñar todo el sistema, incluyendo quién tiene la clave y dónde se descifra. El cifrado de la Outbox en el terminal y el almacenamiento de correos electrónicos en el destino son diferentes.

Si guardas el llavero, ¿no saldrá la clave de Secure Enclave?

Ese no es necesariamente el caso. La implementación confirmada por esta aplicación lee y utiliza datos de clave simétricos de Keychain. No es lo mismo que API, que calcula las claves privadas en Secure Enclave.

Decide el destino y deja una nota de texto
SimpleMemo es una aplicación que deja caracteres escritos en iPhone a la dirección de correo electrónico establecida o Obsidian. Puede comenzar comprobando la conexión y guardando la configuración de destino.
Descargar de App Store

Páginas relacionadas